Nous ne répondons seulement qu'aux sujets dont l'auteur a complété sa signature [Lire]


Multi-boutiques : Ne fonctionne pas !

Soutien général pour les problèmes techniques avec OpenCart

Multi-boutiques : Ne fonctionne pas !

Messagepar i-shop » 28 Mai 2016, 09:32

Bonjour à tous,

J'utilise pour la première fois "Opencart". Par rapport à ce que j'ai pu tester et utiliser auparavant, j'ai été séduit à la fois par sa facilité d'utilisation et sa stabilité.
Pour mon projet en cours, j'ai choisi "Opencart", pour sa fonction native de pouvoir créer plusieurs boutiques "différentes", gérées par une même administration. Malheureusement, il y a un soucis.

Avant de poster cette demande d'aide, j'ai parcouru les forums et le web pour trouver des réponses. Le sujet concernant la création de plusieurs boutiques a été abordé de nombreuses fois et certains avec des tuto.
Seulement, je n'ai rien trouvé en cas d'échec.

Voici ce qui ce passe :
Ma version 2.2 fonctionne très bien sur mon hébergeur quoique je rencontre un peu de difficulté à ajouter un Template. Mais là où ça coince, c'est à l’ajout d'une nouvelle boutique.
J'ai respecté à la lettre les explications trouvées sur les forums ou les tutos. J'ai appliqué le principe du sous-domaine.
La boutique est "apparemment" bien crée, mais IMPOSSIBLE d'y accéder et de la gérer. quoique je fasse, je retombe toujours sur la boutique par défaut. Je ne voie aucun changement dans les codes sources.
Si quelqu'un pouvait m'aider, je lui en serais reconnaissant. Sinon, je devrais, avec regret, passer à autre chose.

Merci d'avance.
Dernière édition par i-shop le 01 Juil 2016, 17:55, édité 1 fois.
Webmaster amateur.
Projet : Mise en place pour juin 2016 d'une plateforme multi-boutiques de préférence avec "Opencart".
Version Opencart : 2.2.0.0
Hébergeur mutualisé.
Installation : OK
i-shop
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 8
Inscription: 27 Mai 2016, 07:26

Re: Multi-boutiques : Ne fonctionne pas !

Messagepar Creastyle » 01 Juil 2016, 11:28

Hello, comme cela à été dit à plusieurs reprises la version 2 d'opencart est très peu suivie ici, n'étant pas assez stable nous préférons te conseiller une version 1.5.6.4 fr téléchargeable sur ce même portail.
Version d'OpenCart : 2.2.0.0
https://www.creastyle[point]fr
- Hébergeur : Planet Hoster World pack
- Modules installés : SSL Certificat, Complet SEO,T-shirt designer Ecommerce, Livezilla, Acute category manager, Pro Email Template, Quick Order Status Updater, Auto review by sms, Lightning cache, Product/Category description générator
- Template installé : Journal 2
- Version du PHP : 5.4.35

Le secret du changement consiste à concentrer son énergie pour créer du nouveau, et non pas pour se battre contre l'ancien. Dan Millam
Avatar de l’utilisateur
Creastyle
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 342
Inscription: 18 Avr 2015, 06:46

Re: Multi-boutiques : Ne fonctionne pas !

Messagepar i-shop » 01 Juil 2016, 13:21

Bonjour et merci pour cette réponse.
Je dois comprendre que si j'utilise la version 1.5.6.4 au lieu de la plus récente, je pourrais développer en multi-boutiques ? C'est intéressant et à la fois étrange de savoir qu'une version récente pose problème.

Je vais essayer, et si c'est concluant, je reviendrais le confirmer ici.
Webmaster amateur.
Projet : Mise en place pour juin 2016 d'une plateforme multi-boutiques de préférence avec "Opencart".
Version Opencart : 2.2.0.0
Hébergeur mutualisé.
Installation : OK
i-shop
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 8
Inscription: 27 Mai 2016, 07:26

Re: Multi-boutiques : Ne fonctionne pas !

Messagepar i-shop » 01 Juil 2016, 13:59

Bonjour,

Après 2 essais, la version 1.5.6.4 est pire que la version 2.
Impossible d'entrer dans l'admin, et le front-office est complètement déstructuré apparemment, sans Template ou sans css.

Merci quand-même.
Webmaster amateur.
Projet : Mise en place pour juin 2016 d'une plateforme multi-boutiques de préférence avec "Opencart".
Version Opencart : 2.2.0.0
Hébergeur mutualisé.
Installation : OK
i-shop
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 8
Inscription: 27 Mai 2016, 07:26

Re: Multi-boutiques : Ne fonctionne pas !

Messagepar Creastyle » 01 Juil 2016, 14:01

Heuu tu dois avoir un problème d'installation j'utilise la 1.5.6.4 et elle fonctionne à merveille
Version d'OpenCart : 2.2.0.0
https://www.creastyle[point]fr
- Hébergeur : Planet Hoster World pack
- Modules installés : SSL Certificat, Complet SEO,T-shirt designer Ecommerce, Livezilla, Acute category manager, Pro Email Template, Quick Order Status Updater, Auto review by sms, Lightning cache, Product/Category description générator
- Template installé : Journal 2
- Version du PHP : 5.4.35

Le secret du changement consiste à concentrer son énergie pour créer du nouveau, et non pas pour se battre contre l'ancien. Dan Millam
Avatar de l’utilisateur
Creastyle
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 342
Inscription: 18 Avr 2015, 06:46

Re: Multi-boutiques : Ne fonctionne pas !

Messagepar i-shop » 01 Juil 2016, 14:10

Ah ! Alors, j'ai pas de chance !
J'utilise le cPanel de l'hébergeur Obambu. Il y a beaucoup de cms préinstallés, donc venant de pros, je suppose qu'il ne devrait pas avoir de problèmes avec leur installateur.
Chez eux, j'ai aussi essayé "Prestashop" et "Magento". Là, les sites fonctionnent bien, mais pour les multi-boutiques, ça ne marche pas.
:twisted:
Webmaster amateur.
Projet : Mise en place pour juin 2016 d'une plateforme multi-boutiques de préférence avec "Opencart".
Version Opencart : 2.2.0.0
Hébergeur mutualisé.
Installation : OK
i-shop
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 8
Inscription: 27 Mai 2016, 07:26

Re: Multi-boutiques : Ne fonctionne pas !

Messagepar Creastyle » 01 Juil 2016, 14:19

Ca c'est une erreur à ne pas faire, les app pré-installée ne sont souvent pas à jour et les bug non corrigés, la version 1.5.6.4 fr est à télécharger sur ce portail !

http://opencart-france.fr/index.php?route=download/download_full
Version d'OpenCart : 2.2.0.0
https://www.creastyle[point]fr
- Hébergeur : Planet Hoster World pack
- Modules installés : SSL Certificat, Complet SEO,T-shirt designer Ecommerce, Livezilla, Acute category manager, Pro Email Template, Quick Order Status Updater, Auto review by sms, Lightning cache, Product/Category description générator
- Template installé : Journal 2
- Version du PHP : 5.4.35

Le secret du changement consiste à concentrer son énergie pour créer du nouveau, et non pas pour se battre contre l'ancien. Dan Millam
Avatar de l’utilisateur
Creastyle
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 342
Inscription: 18 Avr 2015, 06:46

Re: Multi-boutiques : Ne fonctionne pas !

Messagepar i-shop » 01 Juil 2016, 14:40

Re,
Je dois vous paraître un peu nul, mais je faisais confiance.
J’essaierais l'installation manuelle.
Merci pour le tuyau !

;)
Webmaster amateur.
Projet : Mise en place pour juin 2016 d'une plateforme multi-boutiques de préférence avec "Opencart".
Version Opencart : 2.2.0.0
Hébergeur mutualisé.
Installation : OK
i-shop
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 8
Inscription: 27 Mai 2016, 07:26

Re: Multi-boutiques : Ne fonctionne pas !

Messagepar Creastyle » 01 Juil 2016, 15:06

Oui en fait c'est une technique commerciale des hébergeurs pour mieux vendre leurs produits ils proposent des installation en un clic de quelques cms connus, seulement après avoir testé plusieurs d'entre eux je peux affirmer qu'aucun ne fonctionne correctement, il vaut mieux installer manuellement ce genre de scripts.
Version d'OpenCart : 2.2.0.0
https://www.creastyle[point]fr
- Hébergeur : Planet Hoster World pack
- Modules installés : SSL Certificat, Complet SEO,T-shirt designer Ecommerce, Livezilla, Acute category manager, Pro Email Template, Quick Order Status Updater, Auto review by sms, Lightning cache, Product/Category description générator
- Template installé : Journal 2
- Version du PHP : 5.4.35

Le secret du changement consiste à concentrer son énergie pour créer du nouveau, et non pas pour se battre contre l'ancien. Dan Millam
Avatar de l’utilisateur
Creastyle
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 342
Inscription: 18 Avr 2015, 06:46

Re: Multi-boutiques : Ne fonctionne pas !

Messagepar i-shop » 01 Juil 2016, 15:27

Re,

Je n'en doute pas.
Je viens de faire une installation manuelle. Tout s'est bien passé, mais le résultat final est le même.
Je vous laisse le lien de la boutique qui vient d'être installée au cas où vous auriez une idée. Ensuite, je désinstalle.
http://inoveel.com/ishop/
:cry:
Webmaster amateur.
Projet : Mise en place pour juin 2016 d'une plateforme multi-boutiques de préférence avec "Opencart".
Version Opencart : 2.2.0.0
Hébergeur mutualisé.
Installation : OK
i-shop
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 8
Inscription: 27 Mai 2016, 07:26

Re: Multi-boutiques : Ne fonctionne pas !

Messagepar LeorLindel » 01 Juil 2016, 17:01

Bonjour, je ne vois rien d'anormal à cette installation, tout à l'air OK.
Elle ressemble trait pour trait à celle qui se trouve en démo sur le portail.

Qu'est-ce qui te dérange dans cette boutique ?
Image
1 - A lire avant de poster un sujet
2 - Politique sur la signature.

Quand le sujet est résolu, pensez à ajouter la petite coche verte Image dans le titre initial en éditant votre premier message et non dans votre dernière réponse.
Merci


Toutes les extensions commerciales (templates ou modules payants) ne peuvent pas faire l'objet d'ouverture de sujet, prière de bien vouloir s'adresser au concepteur en cas de problème ou demande de renseignements.

Seul, on avance plus vite, à plusieurs on avance plus loin.
Avatar de l’utilisateur
LeorLindel
Administrateur
Administrateur
 
Messages: 4232
Inscription: 19 Fév 2010, 12:44
Localisation: Lutéce

Re: Multi-boutiques : Ne fonctionne pas !

Messagepar i-shop » 01 Juil 2016, 17:17

Bonjour Monsieur,
Vous n'avez sûrement pas visité le bon lien pour affirmer que ce site est comparable à la démo.
http://inoveel.com/ishop/

Cordialement
Webmaster amateur.
Projet : Mise en place pour juin 2016 d'une plateforme multi-boutiques de préférence avec "Opencart".
Version Opencart : 2.2.0.0
Hébergeur mutualisé.
Installation : OK
i-shop
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 8
Inscription: 27 Mai 2016, 07:26

Re: Multi-boutiques : Ne fonctionne pas !

Messagepar LeorLindel » 01 Juil 2016, 17:38

J'ai cliqué sur le lien donné et suis arrivé sur la page d'index que voici :

Image

Je ne vois pas en quoi cela est différent de la version de démo ! :shock: :? :roll:
Image
1 - A lire avant de poster un sujet
2 - Politique sur la signature.

Quand le sujet est résolu, pensez à ajouter la petite coche verte Image dans le titre initial en éditant votre premier message et non dans votre dernière réponse.
Merci


Toutes les extensions commerciales (templates ou modules payants) ne peuvent pas faire l'objet d'ouverture de sujet, prière de bien vouloir s'adresser au concepteur en cas de problème ou demande de renseignements.

Seul, on avance plus vite, à plusieurs on avance plus loin.
Avatar de l’utilisateur
LeorLindel
Administrateur
Administrateur
 
Messages: 4232
Inscription: 19 Fév 2010, 12:44
Localisation: Lutéce

Re: Multi-boutiques : Ne fonctionne pas !

Messagepar Creastyle » 01 Juil 2016, 17:47

Idem pour moi tout à l'air ok, as-tu vidé ton cache navigateur ?
Version d'OpenCart : 2.2.0.0
https://www.creastyle[point]fr
- Hébergeur : Planet Hoster World pack
- Modules installés : SSL Certificat, Complet SEO,T-shirt designer Ecommerce, Livezilla, Acute category manager, Pro Email Template, Quick Order Status Updater, Auto review by sms, Lightning cache, Product/Category description générator
- Template installé : Journal 2
- Version du PHP : 5.4.35

Le secret du changement consiste à concentrer son énergie pour créer du nouveau, et non pas pour se battre contre l'ancien. Dan Millam
Avatar de l’utilisateur
Creastyle
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 342
Inscription: 18 Avr 2015, 06:46

Re: Multi-boutiques : Ne fonctionne pas !

Messagepar i-shop » 01 Juil 2016, 17:54

Re,

Merci à tous les deux. Quand on a pas sa tête, on reste buté sur un problème qui n'existe pas !
Je me suis tout bonnement fait avoir avec le cache !
Une erreur de débutant. J'aurais dû essayer sur un autre navigateur !

Désolé et merci encore ! :oops:
Webmaster amateur.
Projet : Mise en place pour juin 2016 d'une plateforme multi-boutiques de préférence avec "Opencart".
Version Opencart : 2.2.0.0
Hébergeur mutualisé.
Installation : OK
i-shop
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 8
Inscription: 27 Mai 2016, 07:26

Suivante

Retourner vers Soutien Général

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité

cron