Nous ne répondons seulement qu'aux sujets dont l'auteur a complété sa signature [Lire]


Erreur 500 à l'activation de SEO Url

Soutien général pour les problèmes techniques avec OpenCart

Erreur 500 à l'activation de SEO Url

Messagepar jimix974 » 10 Avr 2013, 17:12

bonjour,

Je cherche un tuto pour activer SEO, car de ce que j'ai trouvé sur la toile me mène tout droit a une erreur 500
j'ai activer la fonctionnalité dans opencart, vérifier que mon serveur mamp accepte la réécriture et modifier le fichier.htaccess mais rien a faire ... toujours l'erreur 500

Une idée ou un tuto?
Merci beaucoup
Dernière édition par jimix974 le 14 Avr 2013, 23:50, édité 1 fois.
- Version 1.5.5.1
- Héberger en local
- Version du PHP 5.4.1
jimix974
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 14
Inscription: 04 Avr 2013, 21:44

Re: Erreur 500 à l'activation de SEO Url

Messagepar Jackh69 » 11 Avr 2013, 11:55

Essaies de désactiver cette ligne du htaccess : Options +FollowSymlinks (en haut normalement) en mettant # devant.
OpenCart : 1.5.4 - PHP 5.3.2 - MySQL 5.1.66
Hébergeur : Gandi.Net
Module : nombreux modules (VQMOD)
BonsaiFr.Fr
Jackh69
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 39
Inscription: 08 Déc 2012, 06:54

Re: Erreur 500 à l'activation de SEO Url

Messagepar jimix974 » 11 Avr 2013, 13:31

Merci pour ta réponse,
génial plus d'erreur 500
la page d'accueil fonctionne mais si j’accède a une catégorie (sur laquelle j'ai mis un mot au niveau du paramètre pou la réécriture)
mais la j'ai une erreur 404 ...

je pense que ça fonctionne mais il manque quelque chose la ..

Je crois avoir vu ça sur le forum, je vais essayer de retrouver ...
si jamais t'a la réponse pense a moi ;)

merci beaucoup
jimmy
- Version 1.5.5.1
- Héberger en local
- Version du PHP 5.4.1
jimix974
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 14
Inscription: 04 Avr 2013, 21:44

Re: Erreur 500 à l'activation de SEO Url

Messagepar Jackh69 » 11 Avr 2013, 19:26

Essaies de supprimer la ligne RewriteBase / pareil en ajoutant # devant.

Par contre si tu as ce problème en local tu ne devrais plus l'avoir chez un hébergeur.
OpenCart : 1.5.4 - PHP 5.3.2 - MySQL 5.1.66
Hébergeur : Gandi.Net
Module : nombreux modules (VQMOD)
BonsaiFr.Fr
Jackh69
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 39
Inscription: 08 Déc 2012, 06:54

Re: Erreur 500 à l'activation de SEO Url

Messagepar jimix974 » 11 Avr 2013, 23:02

Toujours pareil

la question que je me pose, est ce que ca fonctionne avec mamp?
- Version 1.5.5.1
- Héberger en local
- Version du PHP 5.4.1
jimix974
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 14
Inscription: 04 Avr 2013, 21:44

Re: Erreur 500 à l'activation de SEO Url

Messagepar Jackh69 » 12 Avr 2013, 00:40

Je ne sais pas mais le problème vient de là car c'est lié à la configuration serveur. Comme ça ne marche pas il te reste soit à tester un autre serveur local (easyphp par exemple) soit activer le mod rewrite d'Apache. Pour la procédure tu trouveras la marche à suivre ici : http://www.apache-mod-rewrite.fr/verifi ... od-rewrite
OpenCart : 1.5.4 - PHP 5.3.2 - MySQL 5.1.66
Hébergeur : Gandi.Net
Module : nombreux modules (VQMOD)
BonsaiFr.Fr
Jackh69
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 39
Inscription: 08 Déc 2012, 06:54

Re: Erreur 500 à l'activation de SEO Url

Messagepar jimix974 » 12 Avr 2013, 08:35

c'était déja activé.
et quand on regarde dans php_info on voit que le module est démarré.
Je vais essayer de tout recommencer. on sais jamais

merci encore
- Version 1.5.5.1
- Héberger en local
- Version du PHP 5.4.1
jimix974
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 14
Inscription: 04 Avr 2013, 21:44

Re: Erreur 500 à l'activation de SEO Url

Messagepar jimix974 » 14 Avr 2013, 23:49

J'ai résolu mon problème.

J'ai recréé un fichier .htaccess en mettant un code que j'ai trouver sur le net et ça fonctionne
Il y a des ligne en moins a comparer au fichier d'origine

Merci encore
- Version 1.5.5.1
- Héberger en local
- Version du PHP 5.4.1
jimix974
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 14
Inscription: 04 Avr 2013, 21:44


Retourner vers Soutien Général

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités

cron