Nous ne répondons seulement qu'aux sujets dont l'auteur a complété sa signature [Lire]


Erreur 1062 lors de création de produits

Inscrire dans ce forum tous les types de problèmes que vous rencontrez avec OpenCart

Erreur 1062 lors de création de produits

Messagepar Cemoa » 03 Fév 2017, 13:47

Bonjour,
Nouveau venu sur ce forum et néophyte absolu en termes de programmation, je rencontre un soucis depuis 2 jours lorsque je tente de créer un nouveau produit. (Je suis sous Opencart Version 1.5.6.4)
Mon site est crée depuis 15 jours :

Serveur : Localhost via UNIX socket
Type de serveur : MySQL
Version du serveur : 5.5.52-0+deb8u1 - (Debian)
Version du protocole : 10

Tout fonctionnait bien pour l'importation ou la création de produits mais depuis 2 jours j'ai un message d'erreur qui s'affiche (quel que soit le procédé, importation de fichier Xls, créations dans la gestion produit d'Opencart et même en copiant un produit existant).
Voici le message d'erreur en question :

Notice: Error: Duplicate entry '774-0' for key 'PRIMARY'
Error No: 1062
INSERT INTO oc_product_to_store SET product_id = '774', store_id = '0' in /var/www/clients/client1/web11/web/system/database/mysql.php on line 50


N'ayant pas de connaissances approfondies en programation je suis quand même allé voir dans Oc Product de PhpMyadmin, j'ai effacé les derniers produits, nettoyé la base, vérifié les IP. J'ai aussi tenté de restaure le fichier mysql.php dans la database de mon site mais rien n'y fait. Je me doute qu'il doit y avoir un problème de codage quelqqu part la dedans mais je ne parviens pas à le trouver ni le résoudre.
Pouvez vous m'aider et m'indiquer quoi faire (et aussi comment) SVP ?
Merci d'avance pour toute votre aide !!!!!!!!!!!!!!!
Nouveau venu en recherche d'aide pour développer son site Opencart
Avatar de l’utilisateur
Cemoa
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 2
Inscription: 03 Fév 2017, 00:29

Re: Erreur 1062 lors de création de produits

Messagepar LeorLindel » 29 Avr 2017, 17:10

Bonjour,

Toutes mes excuses pour la réponse tardive.

L'erreur te signale qu'il y a une entrée en double dans la table "oc_product_to_store" de ta base.

Je te suggère de repartir sur une sauvegarde ou d'effacer les entrées de la table via Phpmyadmin.
Image
1 - A lire avant de poster un sujet
2 - Politique sur la signature.

Quand le sujet est résolu, pensez à ajouter la petite coche verte Image dans le titre initial en éditant votre premier message et non dans votre dernière réponse.
Merci


Toutes les extensions commerciales (templates ou modules payants) ne peuvent pas faire l'objet d'ouverture de sujet, prière de bien vouloir s'adresser au concepteur en cas de problème ou demande de renseignements.

Seul, on avance plus vite, à plusieurs on avance plus loin.
Avatar de l’utilisateur
LeorLindel
Administrateur
Administrateur
 
Messages: 4232
Inscription: 19 Fév 2010, 12:44
Localisation: Lutéce


Retourner vers Rapports de Problèmes

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités

cron