Nous ne répondons seulement qu'aux sujets dont l'auteur a complété sa signature [Lire]


SyntaxError: JSON Parse error: Unrecognized token '<'

Ce forum concerne les problèmes ou solutions d'installation d'OpenCart rencontrés chez cet hébergeur

SyntaxError: JSON Parse error: Unrecognized token '<'

Messagepar Canou83 » 09 Déc 2013, 17:16

Bonsoir à tous.

J'ai depuis quelques jours migré ma boutique sur un nouveau serveur ainsi que la BDD.
Je rencontre un problème avec une fenêtre surgissante (popup) qui me bloque Opencart. Cela n'apparait qu'en Admin et de manière aléatoire et n'obéis à aucune règle. je peux ne pas l'voir pendant 1 heure, et l'heure qui suit la voir s'afficher plusieurs fois. je suis obligé de fermer le navigateur pour la virer. Je précise que je n'ai aucun soucis sur le front, seulement sur le back office.

la fenêtre ressemble à ça mais je n'arrive pas à visualiser la fin de la fenêtre (le bas) :
Image

et la partie du code que je visualise et celle-ci :

Code: Tout sélectionner
http://www.aquamagasin.com
SyntaxError: JSON Parse error: Unrecognized token '<'
OK
<!DOCTYPE html>
<html dir="ltr" lang="fr">
<head>
    <meta charset="UTF-8" />
    <title>Tableau de bord</title>
    <base href="http://www.aquamagasin.com/admin/" />
                <link rel="stylesheet" type="text/css" href="view/stylesheet/stylesheet.css" />
<link rel="stylesheet" type="text/css" href="view/stylesheet/tableedit.css" />
        <link rel="stylesheet" type="text/css" href="view/stylesheet/home_plus.css" media="screen" />
        <script type="text/javascript" src="view/javascript/jquery/jquery-1.7.1.min.js"></script>
<script type="text/javascript" src="view/javascript/tableedit.js"></script>
    <script type="text/javascript" src="view/javascript/jquery/ui/jquery-ui-1.8.16.custom.min.js"></script>
    <link type="text/css" href="view/javascript/jquery/ui/themes/ui-lightness/jquery-ui-1.8.16.custom.css" rel="stylesheet" />
    <script type="text/javascript" src="view/javascript/jquery/tabs.js"></script>
    <script type="text/javascript" src="view/javascript/jquery/superfish/js/superfish.js"></script>
    <script type="text/javascript" src="view/javascript/common.js"></script>
        <script type="text/javascript">
        //-----------------------------------------
        // Confirm Actions (delete, uninstall)
        //-----------------------------------------
        $(document).ready(function(){
            // Confirm Delete
            $('#form').submit(function(){
                if ($(this).attr('action').indexOf('delete',1) != -1) {
                    if (!confirm('Confirmez-vous cette action ?')) {
                        return false;
                    }
                }
            });

            // Confirm Uninstall
            $('a').click(function(){
                if ($(this).attr('href') != null && $(this).attr('href').indexOf('uninstall', 1) != -1) {
                    if (!confirm('Confirmez-vous cette action ?')) {
                        return false;
                    }
                }
            });
        });
    </script>

<style type="text/css">
table.list tbody tr:not([class~=filter]):nth-child(even) td {background: #F8F8FB !important}
table.list tbody tr:not([class~=filter]).selected_row td {background-color:#ffffde !important}
table[class=list] tbody tr:not([class~=filter]):hover td {background: #e7efef !important}
table[class=list] tbody tr:not([class~=filter]).selected_row:hover td {background: #ffefde !important}
</style>
<script type="text/javascript">
$(document).ready(function() {
    $('input[type=checkbox][name^="selected"]').change(function () {
        if ($(this).is(':checked')) {
            $(this).parents('tr').first().addClass('selected_row');


Entre l'ancien hébergement et le nouveau il n'y a pas eu d'installation de nouveaux modules, je suis donc à l'identique. Seule la version d'Opencart est différente, mais avant le passage à la V 1.5.5.2 j'avais également le problème vade la version 1.5.4.1 (identique sur l'ancien serveur).

Merci pour vos pistes.
Dernière édition par Canou83 le 10 Déc 2013, 21:21, édité 2 fois.
Opencart 2.3.0.3 en fr
Journal 2
Avatar de l’utilisateur
Canou83
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 133
Inscription: 09 Déc 2013, 16:33
Localisation: PACA

Re: SyntaxError: JSON Parse error: Unrecognized token '<'

Messagepar Canou83 » 10 Déc 2013, 20:00

Bonsoir.
Je m'auto répond car il semble que le problème soit réglé.

Tout d'abord ce problème n'est finalement nullement lié à Opencart, mais bel et bien à mon hébergeur, en l'occurrence OVH.

Mes sites sont hébergés sur une nouvelle offre 2014 d'OVH : Performance 4

Parallèlement à ce problème de fenêtre surgissante évoquée dans ce sujet, j'avais sur mes 4 sites un problème de déconnexions intempestives uniquement en back office, rien en front. Ce serveur étant en mutualisé, le fichier php.ini n'a aucune influence. Mais les déconnexions bien présentes et la fenêtre aussi.

Hors il semble qu'un problème de cluster chez OVH sur cette offre entrainait ces déconnexions, mais aussi la fenêtre popup, thème de ce sujet. Les cookies de connexions à l'admin se voyaient redirigés à chaque changement de page vers la page login.

Voilà si cela peu aider d'autres. :)
Opencart 2.3.0.3 en fr
Journal 2
Avatar de l’utilisateur
Canou83
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 133
Inscription: 09 Déc 2013, 16:33
Localisation: PACA


Retourner vers OVH

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 0 invités

cron