Nous ne répondons seulement qu'aux sujets dont l'auteur a complété sa signature [Lire]


OpenCart v1.5.5

Nouveautés, Mises à Jour, Messages et Annonces importantes pour OpenCart

OpenCart v1.5.5

Messagepar Malaiac » 21 Jan 2013, 17:25

Personne n'en parle, je me permets de prévenir
que la 1.5.5 a été releasé par Daniel
Mais faites attention à ne pas upgrader en production car un changement de méthode coince toutes les boutiques qui ne sont pas en anglais.
D'apres les premiers retours, il est prudent d'attendre la 1.5.5.1 qui rattrapera cette regression.

Par ailleurs dans le fil de discussion
http://forum.opencart.com/viewtopic.php ... 15#p375215
Daniel parle d'un système de "hook" en préparation, qui peut être très sympa s'il s'inspire des hooks wordpress (pour greffer toutes fonctions sans changer le code principal)
OpenCart 1.5.4.1 - 1and1 mutu - php5.2.17
Malaiac
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 18
Inscription: 19 Jan 2013, 11:10

Re: OpenCart v1.5.5

Messagepar Pamella » 22 Jan 2013, 01:51

Malaiac a écrit:Personne n'en parle, je me permets de prévenir
que la 1.5.5 a été releasé par Daniel
Mais faites attention à ne pas upgrader en production car un changement de méthode coince toutes les boutiques qui ne sont pas en anglais.
D'apres les premiers retours, il est prudent d'attendre la 1.5.5.1 qui rattrapera cette regression.


C'est vrai que j'étais moi-même à 2 ou 3 doigts de me lancer... à propos de cette nouvelle version

apparemment il y a l'arrivé de 'Filters' (dans le Catalogue, Modules) mais je ne sais pas à quoi cela correspond ;-) concraitement... on filtrerait des produits, autrement que par catégorie(s) ?

PS: Qu'est-ce que tu entends par "coince toutes les boutiques (...)" en fait ?
OpenCart v1.5.5.1 avec vQmod v2.3.2 (thème par défaut) - PHP v5.4 - Linux (OVH)

- TelephoneAlwaysOptional1.5.2+ v2.0
- Tracking_Chronopost_et_Colissimo_v152 v1.0.0
Pamella
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 119
Inscription: 24 Oct 2011, 20:52

Re: OpenCart v1.5.5

Messagepar Pamella » 22 Jan 2013, 02:22

il ne reste plus que 'France Metropolitan' avec les départements ;-) question zone
OpenCart v1.5.5.1 avec vQmod v2.3.2 (thème par défaut) - PHP v5.4 - Linux (OVH)

- TelephoneAlwaysOptional1.5.2+ v2.0
- Tracking_Chronopost_et_Colissimo_v152 v1.0.0
Pamella
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 119
Inscription: 24 Oct 2011, 20:52

Re: OpenCart v1.5.5

Messagepar Pamella » 22 Jan 2013, 04:58

Malaiac a écrit:Mais faites attention à ne pas upgrader en production car un changement de méthode coince toutes les boutiques qui ne sont pas en anglais.


Peut-être que ça, en attendant ;-) pourrait faire l'affaire, non ?

Use this vQmod to fix "Call to undefined method Loader::language()" error at OpenCart 1.5.5, while using 1.5.4.1 and earlier extensions.


http://www.opencart.com/index.php?route ... n_id=10158
OpenCart v1.5.5.1 avec vQmod v2.3.2 (thème par défaut) - PHP v5.4 - Linux (OVH)

- TelephoneAlwaysOptional1.5.2+ v2.0
- Tracking_Chronopost_et_Colissimo_v152 v1.0.0
Pamella
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 119
Inscription: 24 Oct 2011, 20:52

Re: OpenCart v1.5.5

Messagepar LeorLindel » 22 Jan 2013, 07:58

Pamella a écrit:il ne reste plus que 'France Metropolitan' avec les départements ;-) question zone

Cette demande, nous l'avions faite à Daniel il y a plus de deux ans, depuis la v1.4.9. Enfin, ce vœu se réalise pour 2013.

En effet cet ID (73 France) était totalement inutile puisque qu'il faisait appel aux régions françaises, chose dont nous n'avons aucune utilité contrairement aux américains qui eux utilisent ce fonctionnement puisque 50 états.

Cela portait vraiment à confusion et avions été obligé de mettre une annotation à cet ID afin qu'aucun client ne puisse s'enregistrer avec celui-ci (France (Régions, ne pas utiliser)). Nous ne pouvions pas le supprimer non plus car dans le code, certaines fonctions faisaient appel à cet ID. Du fait que celui-ci est désormais supprimé, je pense que les fonctions ont étés modifiées dans ce sens.

Ceci est une bien agréable nouvelle.
Image
1 - A lire avant de poster un sujet
2 - Politique sur la signature.

Quand le sujet est résolu, pensez à ajouter la petite coche verte Image dans le titre initial en éditant votre premier message et non dans votre dernière réponse.
Merci


Toutes les extensions commerciales (templates ou modules payants) ne peuvent pas faire l'objet d'ouverture de sujet, prière de bien vouloir s'adresser au concepteur en cas de problème ou demande de renseignements.

Seul, on avance plus vite, à plusieurs on avance plus loin.
Avatar de l’utilisateur
LeorLindel
Administrateur
Administrateur
 
Messages: 4232
Inscription: 19 Fév 2010, 12:44
Localisation: Lutéce

Re: OpenCart v1.5.5

Messagepar Pamella » 22 Jan 2013, 10:20

Une v1.5.5.1 est déjà là... sans trouver de "changelog"

FIXED
set the language class back tot he old style to avoid compatibility problems with extensions
add the load method for language back to the loader class
fixed an issue with deleting categories
OpenCart v1.5.5.1 avec vQmod v2.3.2 (thème par défaut) - PHP v5.4 - Linux (OVH)

- TelephoneAlwaysOptional1.5.2+ v2.0
- Tracking_Chronopost_et_Colissimo_v152 v1.0.0
Pamella
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 119
Inscription: 24 Oct 2011, 20:52

Re: OpenCart v1.5.5

Messagepar gob33 » 26 Jan 2013, 17:32

Je plains d'avance:
- ceux qui vont upgrader leur boutique avec leurs anciennes commandes en code 73 (disparu)
- ceux qui vont vouloir transférer clients et commandes depuis osCommerce ou Zencart (codes 73 et 74)
- ceux qui utilisent un transporteur français avec des tarifs régionaux.
Du grand n'importe quoi.
gob33
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 15
Inscription: 12 Fév 2010, 14:26
Localisation: Bordeaux

Re: OpenCart v1.5.5

Messagepar Malaiac » 27 Jan 2013, 14:17

Oui, Daniel s'est pris de méchantes reflexions sur cette release manifestement mal annoncée et mal préparée
OpenCart 1.5.4.1 - 1and1 mutu - php5.2.17
Malaiac
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 18
Inscription: 19 Jan 2013, 11:10

Re: OpenCart v1.5.5

Messagepar Pamella » 28 Jan 2013, 01:21

quand j'essaie de copier un produit, je perds les options, j'obtiens une erreur mais en faisant 'retour' j'ai tout le reste de copié (ce n'est pas trop grave dans notre cas, très peu de produits, options) mais voilà...

Et un G**gle checkout bouton est apparu dans le panier :-( ou je rêve
OpenCart v1.5.5.1 avec vQmod v2.3.2 (thème par défaut) - PHP v5.4 - Linux (OVH)

- TelephoneAlwaysOptional1.5.2+ v2.0
- Tracking_Chronopost_et_Colissimo_v152 v1.0.0
Pamella
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 119
Inscription: 24 Oct 2011, 20:52

Re: OpenCart v1.5.5

Messagepar Pamella » 05 Fév 2013, 03:15

Comme il semble que 2 ou 3 corrections (qui m'intéressent) ont été uploadé chez GitHub et si j'ai bien tout compris, sur le site officiel le lien de téléchargement est régulièrement mis-à-jour...

donc il y a maintenant je ne sais combien de variante de cette v1.5.5.1 ;-) bien, enfin façon de parler...

mais alors si je veux en profiter... comment faire? simplement écraser les fichiers ou doit-on suivre la procédure de mise-à-jour classique? reste que là on va passer d'une v1.5.5.1 à une autre v1.5.5.1

Une idée, non? quelqu'un aurait peut-être déjà essayé, non?
OpenCart v1.5.5.1 avec vQmod v2.3.2 (thème par défaut) - PHP v5.4 - Linux (OVH)

- TelephoneAlwaysOptional1.5.2+ v2.0
- Tracking_Chronopost_et_Colissimo_v152 v1.0.0
Pamella
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 119
Inscription: 24 Oct 2011, 20:52

Re: OpenCart v1.5.5

Messagepar LeorLindel » 05 Fév 2013, 03:41

T"écrase tout avec la dernière version.
Personnellement, je ne vois vraiment pas l’intérêt de remplacer une version stable (v1.5.4) par une version non stable ou qui essaie de l'être....., mais bon, privilégier la dernière version au détriment de son fonctionnement, pourquoi pas !!.
Image
1 - A lire avant de poster un sujet
2 - Politique sur la signature.

Quand le sujet est résolu, pensez à ajouter la petite coche verte Image dans le titre initial en éditant votre premier message et non dans votre dernière réponse.
Merci


Toutes les extensions commerciales (templates ou modules payants) ne peuvent pas faire l'objet d'ouverture de sujet, prière de bien vouloir s'adresser au concepteur en cas de problème ou demande de renseignements.

Seul, on avance plus vite, à plusieurs on avance plus loin.
Avatar de l’utilisateur
LeorLindel
Administrateur
Administrateur
 
Messages: 4232
Inscription: 19 Fév 2010, 12:44
Localisation: Lutéce

Re: OpenCart v1.5.5

Messagepar Pamella » 05 Fév 2013, 23:55

Merci et oui tu as raison ;-) mais après 6 mois (depuis cette 1.5.4) j'ai craqué et je n'avais pas du tout percuté que même parmi les téléchargement il y avait des "beta" versions,

comme on n'est pas une "vraie" boutique, on peut se permettre de jouer... mais en fait comme tu dis, cette v1.5.5 semble encore en-cours de construction, mieux vaut aimer le code et avoir une certaine expérience ;-) ce qui n'est pas trop mon cas
OpenCart v1.5.5.1 avec vQmod v2.3.2 (thème par défaut) - PHP v5.4 - Linux (OVH)

- TelephoneAlwaysOptional1.5.2+ v2.0
- Tracking_Chronopost_et_Colissimo_v152 v1.0.0
Pamella
Utilisateur enregistré
Utilisateur enregistré
 
Messages: 119
Inscription: 24 Oct 2011, 20:52


Retourner vers Nouveautés et Annonces

Qui est en ligne

Utilisateurs parcourant ce forum: Aucun utilisateur enregistré et 1 invité

cron